Sporadic 504 Errors
Incident Report for Heap
Resolved
We've identified the root cause of this issue, a misconfiguration in a core database server. We've updated the problematic configuration, and have deployed additional monitoring for this class of error.
Posted Aug 26, 2015 - 13:20 PDT
Investigating
Due to sharp increases in data volume, our data collection endpoint sent sporadic 504 (Gateway Timeout) messages between 11:40AM and noon PDT. This may have resulted in dropped data during this period for some customers.

The issue appears to be over now, but we're still investigating the underlying errors. Once we've understood the root cause, we'll provide an update, and mark the incident as resolved.
Posted Aug 26, 2015 - 12:10 PDT