Temporary disruption in data collection.
Incident Report for Heap
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 19:08 PDT
Update
We are continuing to monitor for any further issues.
Posted Apr 26, 2024 - 13:56 PDT
Update
We experienced a brief disruption in data collection between 7:14am and 7:19am UTC. Data captured during this 5 minute timeframe may experience increased latency before it’s available within the app - we will provide updates as this latency is resolved. We recommend customers retry any server-side track and add user property requests that were sent during this time period.

Heap Connect syncs that were running during this time were also interrupted but have since recovered.
Posted Apr 26, 2024 - 13:52 PDT
Monitoring
We experienced a brief disruption in data collection between 7:14am and 7:19am UTC. Data captured during this 5 minute timeframe may experience increased latency before it’s available within the app - we will provide updates as this latency is resolved. We recommend customers retry any server-side track and add user property requests that were sent during this time period.

Heap Connect syncs that were running during this time were also interrupted but have since recovered.
Posted Apr 26, 2024 - 13:47 PDT
Identified
We experienced a brief disruption in data collection between 7:14 am and 7:19 am UTC.

We are investigating any possible data loss in that window, and will provide an update within 24 hours.
Posted Apr 26, 2024 - 00:53 PDT
This incident affected: Data Collection and Heap Connect.