Temporarily Slow Queries
Incident Report for Heap
Resolved
This incident has been resolved.
Posted Oct 21, 2014 - 00:13 PDT
Investigating
You may notice that reports have been loading more slowly today than normal. This is due to an ongoing maintenance job that's adding increased load on our cluster. We hope to complete this job and make sure query speed is back to normal by the end of the day.

Data collection is unaffected.
Posted Oct 20, 2014 - 12:30 PDT