Temporarily Slow Queries
Incident Report for Heap
Resolved
Issues with query speeds should be resolved now!
Posted Mar 03, 2015 - 15:11 PST
Investigating
You may notice that query results are loading more slowly today than normal. We're actively digging into the issue now, and we hope to bring query speed back to normal by the end of the day.

Data collection is unaffected.

We're working on a number of features to help our query and ingestion infrastructure scale more gracefully.
Posted Mar 03, 2015 - 10:23 PST