Intermittent querying issues
Incident Report for Heap
Resolved
All set!
Posted Sep 11, 2014 - 15:35 PDT
Investigating
Our querying cluster is currently experiencing heavy load. This may cause data to take longer than normal to appear in your dashboard, and it may cause some reports to time out.

We're working on resolving the issue now and expect to have everything up to speed within a few hours.
Posted Sep 11, 2014 - 10:58 PDT