Temporary Data Latency
Incident Report for Heap
Resolved
All set!
Posted May 18, 2015 - 15:44 PDT
Identified
Query speed should be back to normal. We're working on clearing the data backlog, hope to resolve the issue by end of day.
Posted May 18, 2015 - 09:08 PDT
Investigating
Some customers may notice data taking longer than usual to appear in your dashboard. Additionally, queries may be running more slowly than normal.

Data collection is unaffected, and no data has been lost. We expect this issue to be resolved by 10:00am PST.
Posted May 18, 2015 - 00:39 PDT