Some Queries Timing Out
Incident Report for Heap
Resolved
We're all set!
Posted Jul 25, 2014 - 17:40 PDT
Investigating
We're currently experiencing a high throughput of data. This may cause some intermittent query timeouts in your dashboard.

We're working on resolving the issue now, and expect to have everything functioning normally by 6:30 PM PDT.
Posted Jul 25, 2014 - 16:19 PDT